Email Delays

Incident Report for Swan Bitcoin

Resolved

This incident has been resolved.
Posted Mar 24, 2025 - 21:22 UTC

Investigating

Our email service provider is experiencing delays in sending emails. This is impacting all our operational emails. We apologize for the inconvenience caused. We will update this page as we receive updates from our partner.
Posted Mar 24, 2025 - 15:17 UTC
This incident affected: Operational Emails.