IRA Accounts: Temporary Bitcoin Purchasing Outage

Incident Report for Swan Bitcoin

Resolved

This incident has been resolved.
Posted Mar 27, 2025 - 18:03 UTC

Update

We are continuing to investigate this issue.
Posted Mar 27, 2025 - 17:21 UTC

Update

We are continuing to investigate this issue.
Posted Mar 27, 2025 - 16:41 UTC

Investigating

We are investigating a potential Bitcoin purchasing outage on IRA Accounts.

Some clients may be temporarily unable to buy Bitcoin in IRA accounts. All other IRA functionality is available and Bitcoin purchasing in personal accounts remains operational.

Our apologies for any inconvenience caused. We will post updates to this page as soon as we have further information.
Posted Mar 27, 2025 - 16:30 UTC
This incident affected: Custody and Trading - IRA Accounts (Equity Trust) (Instant Buys, Convert Now, Savings Plans).