ACH deposit outage
Incident Report for Swan Bitcoin
Resolved
This incident has been resolved.
Posted Mar 20, 2024 - 12:36 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 20, 2024 - 12:05 UTC
Investigating
We are investigating an ACH deposit outage.

Our apologies for any inconvenience caused.

We will post updates to this page as soon as we have further information.
Posted Mar 20, 2024 - 11:57 UTC
This incident affected: Custody and Trading - Fortress (Instant Buys, Savings Plans).