Instant Buys Outage
Incident Report for Swan Bitcoin
Resolved
Instant buys are operational. This incident is resolved.
Posted Oct 28, 2023 - 10:12 UTC
Investigating
We are investigating an outage with Instant Buys

Our apologies for any inconvenience caused. We will post updates to this page as soon as we have further information.
Posted Oct 28, 2023 - 07:44 UTC
This incident affected: Custody and Trading - Fortress (Instant Buys).