Issues with ACH deposits settling
Incident Report for Swan Bitcoin
Resolved
This incident has been resolved.
Posted Feb 27, 2024 - 20:21 UTC
Investigating
We have been notified that our Bitcoin trading partner is experiencing issues with ACH deposits settling.

Our apologies for any inconvenience caused. We will post updates to this page as soon as we have further information.
Posted Feb 27, 2024 - 16:44 UTC
This incident affected: Custody and Trading - Fortress (Instant Buys, Savings Plans).