Bitcoin Purchasing Outage
Incident Report for Swan Bitcoin
Resolved
This incident has been resolved.
Posted Mar 05, 2024 - 11:27 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 05, 2024 - 11:19 UTC
Investigating
The Bitcoin trading platforms connected to our service are experiencing an outage. As such, you may be unable to buy Bitcoin at this time.

We are working with our partners on resolving these errors immediately. We will continue to monitor and provide updates here as we come to a resolution. Our sincere apologies for the inconvenience.
Posted Mar 05, 2024 - 10:00 UTC
This incident affected: Custody and Trading - Fortress (Instant Buys, Convert Now, Savings Plans).