Website Log In and Access Issues
Incident Report for Swan Bitcoin
Resolved
This incident has been resolved.
Posted Jan 23, 2024 - 22:56 UTC
Investigating
We are facing issues with our web application, which means some of our site functionality may be unavailable.

Our apologies for any inconvenience caused. We will update this page with further information.
Posted Jan 23, 2024 - 22:48 UTC
This incident affected: Swan Website and Custody and Trading - Fortress (Withdrawals, Instant Buys, Convert Now, Savings Plans).