Swan Vault web interface unavailable
Incident Report for Swan Bitcoin
Resolved
This incident has been resolved.
Posted Apr 23, 2024 - 20:49 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 23, 2024 - 20:33 UTC
Investigating
Swan Vault is currently unavailable to view in your Swan Dashboard. We're actively working to resolve the issue and we will post updates here. You can still access your Vaults via Specter Desktop.

Our apologies for any inconvenience caused.
Posted Apr 23, 2024 - 19:57 UTC
This incident affected: Swan Vault.