SMS Delays
Incident Report for Swan Bitcoin
Resolved
This incident has been resolved.
Posted Jan 05, 2024 - 07:01 UTC
Investigating
Our SMS service provider is experiencing issues in sending SMS. This is impacting our verification and operational SMS. We apologize for the inconvenience caused. We will update this page as we receive updates from our partner.
Posted Jan 04, 2024 - 14:21 UTC
This incident affected: Swan Website, Swan iOS App, and Swan Android App.