Delay in Opening New Accounts
Incident Report for Swan Bitcoin
Resolved
This incident has been resolved.
Posted Oct 08, 2024 - 22:21 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 08, 2024 - 22:16 UTC
Identified
Our onboarding partner is experiencing issues that will delay opening a new account. They are actively working to resolve the issue.

Our apologies for any inconvenience caused. We will update this page as we receive further information from our partner.
Posted Oct 08, 2024 - 22:09 UTC
This incident affected: Onboarding - Fortress (Account creation) and Onboarding - Bakkt (Account creation).